Ankündigung

Einklappen
Keine Ankündigung bisher.

transfer speed von dual extruder

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • transfer speed von dual extruder

    hallo freunde, arbeite mich gerade mit dual extruder ein und habe das problem, dass beim "transfer" die extruder viel zu schnell bewegt werden, dadurch geht bei jedem mal die position ein bisschen verloren, das heisst der ausdruck wird schief. wo kann ich diese geschwindigkeit im g-code einstellen? alle info hilft mir weiter, danke

  • #2
    ... die wird üblicherweise im Slicer-Programm eingestellt.
    Aber irgendwie kann ich mir nicht vorstellen, dass das Dein Problem sein soll.
    Drucke mal 2 Objekte (Testwürfel) , die diagonal verteilt auf dem Druckbett stehen.

    Kommentar


    • #3
      guten Morgen Horst, danke für die Antwort. Mit dem Druck von 2 Objekten bin ich im Moment überfordert. Das "Slicer" Programm, entspricht das dem g-code? Und wo würde diese Anweisung stehen? Ich habe mit "find" nach "speed, transfer, move" gesucht, aber bin da nicht fündig geworden. Danke, Edi

      Kommentar


      • #4
        Ohje, das sieht ja schlimm aus.

        Mit einem Slicer-Programm wird aus einer STL-Datei der G-Code erzeugt. ASlso Simplify, Cura, Slic3r oder eben Hersteller-eigene Lösungen.
        Mit dem Doppeldruck ist ganz einfach, das Modell im Slicer duplizieren und die Teile entsprechend verschieben. Das können alle Slicer. Denke ich mal. Ansonsten 2 x importieren geht ja auch, oder 2 verschiedene Modelle in etwa gleicher Höhe.
        Zweck der Übung ist, mit etwas Glück erkennen zu können, an was die Misere liegen könnte. Nach dem Bild zieht sich eine Biegung über die ganze Frontlinie. Wenn dem so ist, dann liegt eine nicht richtige Einstellung der Motorschritte nahe.
        Und um das besser beurteilen zu können, drehe bitte auch 1 Exemplar der Modelle um 90°, damit es "Quer" gedruckt wird. Wenn die Biegung in der Querrichtung auch vorkommt, ist die Sache ziemlich klar. Kalibrierung ist das Stichwort.
        An die Korrektur der sonstigen Druckeinstellungen gehst Du bitte später, das spielt zunächst keine Rolle, erst mal die "Verschiebung" in den Griff bekommen. Wenn Du allerdings merkst, dass die Düse im Verlauf des Druckens gegen die Oberkante des Drucks "rammelt", dann muss man da erst mal etwas korrigieren, denn das könnte die Verschiebung in der Tat auch auslösen.

        Kommentar


        • #5
          danke für die ausführliche Darlegung. Als slicer benutze ich "ReplicatorG", der das mergen recht einfach macht. Siehe auch die Beschreibung auf:
          http://zhaidazz.wixsite.com/3dprinte...h-replicator-g. Da wird genau beschrieben, wie man vorzugehen hat - und das funktioniert ja auch. Mein Gefühl ist, dass die Positionsänderung von einer Düse zur anderen viel zu schnell geht, der Schrittmotor hat eine unglaubliche Geschwindigkeit und es hört sich an, wie wenn er da eine unsaubere Bewegung macht, und darum wohl ein bisschen über das Ziel hinausfährt. So interpretiere ich, dass für diese Pos-Aenderung der Schrittmotor Befehl zu hoch / schnell ist. Kann man das im g-code ändern? Wenn ja, wo steckt der Befehl? Danke für die Geduld, Edi

          Kommentar


          • #6
            Ich kenne mich da zwar nicht aus (rep habe ich noch nicht mal installiert) aber ich denke, dass das keine Sache des Slicers ist (Travel Speed), sondern in den Einstellungen der Firmware liegt.
            Ein Schrittmotor macht genau das, was ihm befohlen wird, nicht mehr und nicht weniger. Wenn die Geschwindigkeit hoch eingestellt ist (Slicer >>> GCode) und die Spannung für den Motor niedrig, kann es bei der hohen Anforderung an Beschleunigung usw, zu Schrittverlusten kommen, die sich dann so äußern wie gezeigt.
            Was hast Du denn als TravelSpeed bzw Druckgeschwindigkeit eingestellt?

            Aber da soll Dir bitte jemand anderes helfen, ich bin da am Ende meiner Fahnenstange.

            Kommentar


            • #7
              hallo, bei den Einstellungen zur g-code generierung sehe ich feed-rate (mm/s): 50, travel feedrate: 50.
              Ist es wohl die travel feedrate, die zu hoch ist? - merkte das aber beim single print nie.
              Herzlichen Dank, Gruss Edi

              Kommentar


              • #8
                feed-rate ist die Druckgeschwindigkeit, bei travel-Feed-rate müsste ich raten - ganz wie der Name sagt ;-) sagt mir aber nichts. Die Bewegung des Druckkopfs in Druckrichtung zieht m.E. die Extrusionsgeschwindigkeit automatisch nach sich, zumindest ist in S3D ´da nichts gesondert einstellbar. Dort nennt sich die "Reise-Geschwindigkeit", also die Geschwindigkeit, mit der sich der Druckkopf bewegt, wenn nicht extrudiert wird, TravelSpeed. Und die Druckgeschwindigkeit heißt ganz lapidar "PrintingSpeed". Unterklassen der Speeds werden in %-Anteilen bestimmt.
                Das Umschalten von einer Düse auf die andere kann man in S3D nicht einstellen, ich nehme an, dass das max die TravelSpeed sein kann, denn die ist weit höher als die Druckgeschwindigkeit.

                Beim Dualdruck ist neben anderen Dingen auch die Einstellung des Abstands der Düsen wichtig. Stimmt der?

                Kommentar


                • #9
                  Hallo, der Arbeitstag ist zu Ende, jetzt geht es mit dem Hobby weiter. Ich gehe davon aus, dass die TravelSspeed zu hoch ist, wie Du so schön sagst "wenn nicht extrudiert wird". Werde das mal reduzieren und dann weiter sehen. Der Düsenabstand ist durch die Mechanik gegeben, sieht auch zu Beginn in Ordnung aus - nur im Verlauf des Druckes verschiebt sich die Position der Druckköpfe jedesmal ein bisschen. Danke für die Geduld mit mir.

                  Kommentar


                  • #10
                    ... ja natürlich durch die Mechanik gegeben! Was sonst. Aber dieser Wert muss dem Programm auch mitgeteilt werden und das auch noch richtig!

                    Kommentar


                    • #11
                      hallo, ich denke das weiss das Programm / der Drucker, da ja die 2. Farbe vorerst richtig positioniert. Gestern habe ich noch den Wert von "travel-feed rate" von 40 auf 10 runtergestellt - der Transfer findet nun in einem vernünftigen Tempo statt. Aber die Y- Geschw. habe ich noch nicht im Griff. Immerhin ein Fortschritt!
                      In der Zwischenzeit habe ich auch noch eine g-code Uebersicht gefunden: 3dee.at/info/g-code-uebersicht. Das scheint aber auch für CNC Ansteuerungen gebraucht zu werden.
                      Habe also noch ein bisschen zu pröbeln. Nochmals Danke für die Geduld mit einem Anfänger.

                      Kommentar


                      • #12
                        Verstehe ich das jetzt richtig. Du hast den Travel Speed von 40mm/s auf 10mm/s verringert damit der Drucker besser arbeitet und keine Schritte verliert?

                        Dann mußt Du die Druckgeschwindigkeiten genauso reduzieren

                        Wohh. Da kann ich nicht mitreden. Bei mir ist das je nach Drucker mit 150 bis 400mm/s für Travel eingestellt und Drucken tu ich zwischen 80 und 300mm/s ohne Schritt und Qualitätsverluste.
                        Da stimmt bei Dir was Grundsätzliches nicht, da auch ein Da Vinci 80mm/s abkönnen muß und Du solltest mal den Support anschreiben. Machen kann man da bei diesem Drucker ja nicht viel selbst wenns ein Da Vinci ist.

                        Kommentar


                        • #13
                          N'Abend Apa!
                          Wenn die Reduzierung der Travelgeschwinigkeit einen Sinn haben kann, dann höchstens um zu sehen, ob die Verschiebung dann auch noch vorkommt. Wenn Nein, dann ist wirklich irgendwo am Innenleben etwas faul. An Slicerproblem glaube ich eh nicht. Wenn der Fehler bleibt, dann eher mechanisches Problem oder ein Motor / Treiber hat Macken. Sowas soll doch vorkommen, gell ;-)

                          Beste Grüße nach Grünstadt
                          Horst

                          Kommentar


                          • #14
                            Da hast Du vollkommen recht Horst und es wird auch auf Dauer mit der Reduzierung nicht fuktionieren und verursacht dann auch noch andere Probleme mit dem Hotend die sowieso dauernd verstopfen.

                            Ich hatte diese Da Vinci Dinger schon öfter in Händen, weil die oft nicht funktionieren und es in Deutschland keinen Support mehr gibt. Das Problem ist nur, daß eigendlich schon ein Prusa in vielen Dingen besser funktioniert, obwohl die nichts anderes sind, nur mit Gehäuse und voller lauter prioitärer Bauteilen.
                            Ich kenne jetzt nur einen der es hinbekommen hat indem er seinen Da vici so oft nach Holland zurückgeschickt hat, bis der jetzt endlich auch mal einigermaßen druckt. Die Ergebnisse lassen aber trotzdem keinen vom Hocker fallen und wie lange....

                            Kommentar


                            • #15
                              Ich habe hier gerade aktuell einen wunderbaren Vergleich von Rüdiger, der mir erlaubt hat das Bild zu verwenden.

                              Links in einem Da Vinci und XYZ-Software gedruckt in einem Junior 1.0 der soweit ich informiert bin bisher dreimal zur Reparatur monatelang im Ausland war mit der Einstellung "hohe Qualität und 0,1mm Layerhöhe.
                              Rechts einer seiner ersten Drucke in seinem neuem MKC, ebenfalls mit 0,1mm layerhöhe gedruckt, ohne Optimierung.



                              Kommentar

                              Lädt...
                              X